1. The update is temporarily delayed until droopy returns. Thanks for your patience! It WILL happen ASAP. Stay tuned!

Issues With Ship 2s?

Discussion in 'Technical Forum' started by Green, Feb 24, 2018.

  1. Green

    Green Forum Ensign

    Yeah, yeah, we all should know that a lot Ship 2s and Ship 3s got partially erased due to a -excuse my French- world edit Tarnation up (that's what I've been told). Thus, granting me time to restyle my ship. But, has anyone else seen a string of issues with Ship 2s?

    Speaking for my own Ship 2, the thing now randomly sinks for no reason, usually when leaving the docks.
    For any details, the sinking starts from the back.

    It once turned to air, the air keeping it's basic shape as the ship, then promptly sunk to the bottom of the ocean or whatever you call it. (To be honest, it was actually pretty cool being able to see the different ships that sunk and the effect of crashing into a ship.)

    This is the most recent issue my ship has: When I spawn it, it spawns with a tub of air underneath the ship carving out the water beneath it. That keeps me from commanding the ship safely out of the docks.

    izzcracker recommended removing doors... The suggestion had no effect regarding these issues...

    I have also had issues right before the world edit phenomena, like the ship not responding at all in docks saying "Engines not detected". Even though I checked and rechecked all the engine signs, then the ship disappearing. *I WAS NOT TURNING THE SHIP, NOR EVEN ABLE TO CONTROL IT. JUST MAKING THIS CLEAR BEFORE YOU HIT ME WITH THAT. AND NONE OF THE PROBLEMS NOW EVEN REQUIRE ME TO TURN THE VESSEL.
    Has anyone seen these problems with their own ship?
     
  2. Vulture4117

    Vulture4117 Forum Admiral

    That's "iizcracker" not "izzcracker"
     
  3. MythicalWraith

    MythicalWraith Forum R. Admiral

    The french word for, "f.ck" is "merde." Uncultured swine.
     
  4. TheInventorMan

    TheInventorMan Admin Staff Member Admin

    These are all separate issues, entirely unrelated to both the Shipyard event, and ship2s in general.
    • Tubs of air being formed under the vehicle is due to /stoplag being activated. When /stoplag is activated, it halts all intensive server activity (explosives, water spread, redstone, etc) meaning when you spawn in your ship, the water can't replace itself, therefore leaving a gap. /stoplag is generally only on for shorts amount of time however, usually during large WorldEdit operations.
    • The error with "NO ENGINES DETECTED" is likely due to illegal blocks. To give a simple explanation without getting into a bunch of plugin jargon - the sign only registered part of the vehicle (evidently the part without any engines), and couldn't move. When it inevitably did try to move, it hit the part of the ship it couldn't register, then despawning the whole thing.
    • Flooding can be a number of problems, ranging from both bugs and design error alike. I can try to check the ship out in-detail and fix it when I'm on the server sometime.
    On a more casual note; seeing all the wrecks really is cool. Some of my fondest memories with the plugin are - funnily enough - of trying to survive the flooding after a large sub or ship is sank.
     
    Green likes this.
  5. Green

    Green Forum Ensign

    Thanks
     

Share This Page